您的位置:首页 > 其它

poj-2253-Frogger-最短路

2015-08-04 20:00 435 查看
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30089Accepted: 9708
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming
and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates
of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three
decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


说一下题意,给第一点是青蛙的坐标,第二个是妹子的坐标,其他的点是石头的坐标,现在要问青蛙到妹子的地方,至少需要跳的最大距离,不是最短路问题,路可以很长,跳的石头很多,要求是跳的最大距离,最小,可以构造包括妹子点的最小生成树,然后看下,目前已经连上点上的最大距离,还有一点,用G++的话用f,C++的话用lf可以A,G++会WA,

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define MAX 0x3f3f3f3f
struct node
{
    double x, y;
} ls[210];
double map[250][250];
int n;
double dis[210];
int bj[250];
int kk = 0;
void Dijk()
{
    int pos = 0;
    memset(bj,0,sizeof(bj));
    memset(dis,0,sizeof(dis));
    for(int i = 0; i < n; i++)
        dis[i] = map[pos][i];
    bj[pos] = 1;
    double ans=0;
    for(int i = 0; i < n-1; i++)
    {
        double min = MAX;
        for(int j = 0; j < n; j++)
        {
            if(min > dis[j] && !bj[j])
            {
                min = dis[pos = j];
            }
        }
        bj[pos] = 1;
        if(min>ans)
            ans=min;
        if(pos == 1)
            break;
        for(int j = 0; j < n; j++)
        {
            if(dis[j] > map[pos][j]&& !bj[j])
            {
                dis[j] = map[pos][j];
            }
        }
    }
    printf("Scenario #%d\n",++kk);
    printf("Frog Distance = %.3lf\n",ans);
    printf("\n");
}
int main()
{
    kk = 0;
    while(~scanf("%d",&n)&&n)
    {
        int i,j;
        for(i = 0; i < n; i++)
            scanf("%lf%lf",&ls[i].x,&ls[i].y);
        for(i = 0; i < n; i++)
            for(j = i; j < n; j++)
            {
                map[i][j] = sqrt(pow((ls[i].x - ls[j].x),2)+pow((ls[i].y -ls[j].y),2));
                map[j][i] = sqrt(pow((ls[i].x - ls[j].x),2)+pow((ls[i].y -ls[j].y),2));
            }

        Dijk();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: