您的位置:首页 > 产品设计 > UI/UE

poj-3080-Blue Jeans-串-暴力

2015-08-07 16:10 513 查看
The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.

m lines each containing a single base sequence consisting of 60 bases.

Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities"
instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output
no significant commonalities
AGATAC
CATCATCAT


看是否有连续的子串,子串长度大于3,按照字典序小的优先,暴力枚举串的长度,用strstr这个函数,strstr(a,b),看b是否为a的子串,如果是返回在a的位置的指针,没有返回NULL

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;
char ls[15][65];
char ans[65];
char ub[65];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        cin>>n;
        memset(ans,'\0',sizeof(ans));
        for(int i = 1; i <= n; i++)
            scanf("%s",ls[i]);
        for(int i = 1; i <= 60; i++)
        {
            int flag = 0, k;
            for(int j = 0; j <= 60-i; j++)
            {
                int tp = 0;
                int bj = 1;
                for(k = j;;k++)
                {
                    ub[tp++] = ls[1][k];
                    if(tp == i)
                        break;
                }
                ub[tp]='\0';
                for(k = 2; k <= n; k++)
                {
                    if(!strstr(ls[k],ub))
                    {
                        bj = 0;
                        break;
                    }
                }
                if(bj)
                {
                    flag = 1;
                    if(strlen(ans)<strlen(ub))
                        strcpy(ans,ub);
                    else if(strcmp(ans,ub)>0)
                        strcpy(ans,ub);
                }
            }
            if(!flag)
                break;
        }
        if(strlen(ans)<3)
            printf("no significant commonalities\n");
        else
            printf("%s\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: