您的位置:首页 > 大数据 > 人工智能

HDU 5349 MZL's simple problem (2015 Multi-University Training Contest 5 2015多校联合)

2015-08-04 17:50 465 查看
题目传送门:HDU 5349 MZL's simple problem


MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 107 Accepted Submission(s): 43



Problem Description

A simple problem

Problem Description

You have a multiple set,and now there are three kinds of operations:

1 x : add number x to set

2 : delete the minimum number (if the set is empty now,then ignore it)

3 : query the maximum number (if the set is empty now,the answer is 0)

Input

The first line contains a number N (N≤106),representing
the number of operations.

Next N line
,each line contains one or two numbers,describe one operation.

The number in this set is not greater than 109.

Output

For each operation 3,output a line representing the answer.

Sample Input

6
1 2
1 3
3
1 3
1 4
3


Sample Output

3
4


Source

2015 Multi-University Training Contest 5

Recommend

wange2014

水水的数据结构。用set就可以做了。但是!!!用了cin和cout直接卡超时了有木有!!!

还有要判断不为空!!不然会run time error。访问越界!!!

代码:

#include <cstdio>
#include <algorithm>
#include <set>
#include <iostream>
using namespace std;
int main()
{
int n,a,m;
scanf("%d",&n);
set<int> v;
while(n--)
{
scanf("%d",&m);
if(m==1)
{
scanf("%d",&a);
v.insert(a);
}
if(m==2)
{
std::set<int>::iterator it;
if(v.empty())
continue;
it=v.begin();
v.erase(*it);
}
if(m==3)
{
if(v.empty())
printf("0\n");
else
{
std::set<int>::iterator it;
it=v.end();
it--;
printf("%d\n",*it);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: