您的位置:首页 > 其它

HDU 4727 The Number Off of FFF(水题)

2015-08-03 10:11 218 查看


The Number Off of FFF

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2815 Accepted Submission(s): 937



Problem Description

X soldiers from the famous "*FFF* army" is standing in a line, from left to right.

You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the
soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.

Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers
stands continuously in the original line, from left to right.

We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.



Input

The rst line has a number T (T <= 10) , indicating the number of test cases.

For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 105)

It guaranteed that there is exactly one soldier who has made the mistake.



Output

For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.



Sample Input

2
3
1 2 4
3
1001 1002 1004




Sample Output

Case #1: 3
Case #2: 3




Source

2013 ACM/ICPC Asia Regional Online —— Warmup2

点击打开链接

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int a[100010];
int n;

int main()
{
    int T;
    scanf("%d",&T);
    int k = 0;
    while(T--)
    {
        scanf("%d",&n);
        int flag = 0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=2;i<=n;i++)
        {
            if(a[i]-a[i-1]!=1)
            {
                flag = i;
                break;
            }
        }
        if(flag == 0)
        {
            printf("Case #%d: %d\n",++k,1);
        }
        else
        {
            printf("Case #%d: %d\n",++k,flag);
        }

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: