您的位置:首页 > 其它

Beans

2015-08-03 09:36 323 查看
Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.



Now, how much qualities can you eat and then get ?

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output

For each case, you just output the MAX qualities you can eat and then get.

Sample Input

4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output

242

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[200010],dp[200010];
int f(int x,int b[])
{
int i;
dp[0]=b[0];
dp[1]=max(dp[0],b[1]);
for (i=2;i<x;i++)  dp[i]=max(dp[i-2]+b[i],dp[i-1]);
return dp[x-1];
}
int main()
{
int i,j,n,m,b[200010];
while (~scanf("%d%d",&n,&m))
{
if (n==0&&m==0) break;
for (i=0;i<n;i++)
{
for (j=0;j<m;j++) scanf("%d",&b[j]);
a[i]=f(m,b);
}
printf("%d\n",f(n,a));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: