您的位置:首页 > 其它

hdoj 2199 Can you solve this equation? 【二分基础题 注意去掉不满足的情况】

2015-08-02 22:45 399 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13031 Accepted Submission(s): 5841

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input
2
100
-4




Sample Output
1.6152
No solution!



看了一天网络流,做道简单点的题。

注意当Y < 6 || Y >= sum(100)时,没有解。。。

AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define eps 1e-8
using namespace std;
double sum(double x)
{
    return 8 * pow(x, 4) + 7 * pow(x, 3) + 2 * pow(x, 2) + 3 * x + 6 ;
}
int main()
{
    int t;
    double Y;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf", &Y);
        if(Y < 6 || Y > sum(100))
        {
            printf("No solution!\n");
            continue;
        }
        double left = 0, right = 100.0, mid;
        while(right - left > eps)
        {
            mid = (left + right) / 2;
            if(sum(mid) > Y)
                right = mid;
            else
                left = mid;
        }
        printf("%.4lf\n", left);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: