您的位置:首页 > 其它

hdoj 1686 Oulipo 【求一个串在另一串的出现次数】【KMP】

2015-08-03 12:54 295 查看

Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7117 Accepted Submission(s): 2828

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.



Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.



Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.



Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN




Sample Output
1
3
0




题意:给你一个串P,一个串T,问P在T里面的出现次数。

KMP裸题:注意和hdoj上面的剪花布条不一样。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 1000000+10
#define LL long long
using namespace std;
char P[MAXN], T[MAXN];
int f[MAXN];
void getfail()
{
    int len = strlen(P);
    f[0] = f[1] = 0;
    for(int i = 1; i < len; i++)
    {
        int j = f[i];
        while(j && P[i] != P[j])
            j = f[j];
        f[i+1] = P[i]==P[j] ? j + 1 : 0;
    }
}
void find()
{
    int m = strlen(P);
    int n = strlen(T);
    int i, j = 0;
    LL ans = 0;
    for(i = 0; i < n; i++)
    {
        while(j && T[i] != P[j])
            j = f[j];
        if(T[i] == P[j])
            j++;
        if(j >= m)
        {
            ans++;
            j = f[j];//和剪花布条 区别在这里的处理
            //i = i- m + 2;
            //printf("%d\n", i);
        }
    }
    printf("%lld\n", ans);
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s%s", P, T);
        getfail();
        find();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: