您的位置:首页 > 其它

uva 673 Parentheses Balance(栈)

2015-08-01 20:10 381 查看



Parentheses Balance

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a)if it is the empty string(b)if A and B are correct, AB is correct,(c)if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings
of parentheses () and [], one string a line.

Output

A sequence of Yes or No on the output file.

Sample Input

3
([])
(([()])))
([()[]()])()


Sample Output

Yes
No
Yes


题目大意:确定括号是否匹配。

解题思路:左括号入栈,右括号匹配出栈,注意空语句要输出Yes。

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10

#define maxm 400007
#define maxn 1000009

using namespace std;

int main()
{
char s[150];
bool flag;

int n;
scanf("%d",&n);
getchar();
while(n--)
{
flag=true;
memset(s,0,sizeof s);
gets(s);
int len=strlen(s);

stack<char>q;
for(int i=0;i<len;i++)
{
if(s[i]=='('||s[i]=='[')
{
q.push(s[i]);
}
else if(s[i]==')')
{
if(q.empty()||q.top()!='(')
{
flag=false;
break;
}
else
{
q.pop();
}
}
else if(s[i]==']')
{
if(q.empty()||q.top()!='[')
{
flag=false;
break;
}
else
{
q.pop();
}
}
}
if(flag&&q.empty())
puts("Yes");
else
puts("No");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: