您的位置:首页 > 其它

hdoj.5120 Intersection【计算几何-两圆相交面积】 2015/08/01

2015-08-01 20:05 393 查看

Intersection

Time Limit: 4000/4000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 975 Accepted Submission(s): 374

[align=left]Problem Description[/align]
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.



A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.



Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

[align=left]Input[/align]
The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.

[align=left]Output[/align]
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

[align=left]Sample Input[/align]

2
2 3
0 0
0 0
2 3
0 0
5 0


[align=left]Sample Output[/align]

Case #1: 15.707963
Case #2: 2.250778


[align=left]Source[/align]
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

注:两圆相交面积模板,只需要计算出三部分面积即可,s1(两大圆相交面积)、s2(大圆与小圆相交面积)、s3(小圆与小圆相交面积)
最后圆环相交面积即为s=s1+s3-2*s2
#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

double min(double a,double b){
return a>b?b:a;
}

double overlap_area(double x1,double y1,double r1,double x2,double y2,double r2){
double d = sqrt( (x1-x2)*(x1-x2) + (y1-y2)*(y1-y2) );
double angle1,angle2,h1,h2,s1,s2;
if( d >= r1+r2 )
return 0;
if( d <= fabs(r1-r2) )
return min( acos(-1.0)*r1*r1 , acos(-1.0)*r2*r2 );
angle1 = acos( (d*d+r1*r1-r2*r2) / (2*d*r1) );
angle2 = acos( (d*d+r2*r2-r1*r1) / (2*d*r2) );
h1 = angle1 * r1 * r1;
h2 = angle2 * r2 * r2;
s1 = r1 * r1 * cos(angle1) * sin(angle1);
s2 = r2 * r2 * cos(angle2) * sin(angle2);
return h1 + h2 - (s1+s2);
}

int main(){
int t , ans = 1;
double x1,y1,x2,y2,r1,r2;
cin>>t;
while(t--){
scanf("%lf%lf%lf%lf%lf%lf",&r1,&r2,&x1,&y1,&x2,&y2);
double dada = overlap_area( x1,y1,r1,x2,y2,r1 );
double daxiao = overlap_area( x1,y1,r1,x2,y2,r2 );
double xiaoxiao = overlap_area( x1,y1,r2,x2,y2,r2 );
double ss = dada - 2 * daxiao + xiaoxiao;
printf("Case #%d: %.6lf\n",ans++,ss);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: