您的位置:首页 > 其它

SDUT2015暑假集训14级周赛1 E - 尤文图斯(NP-博弈)

2015-08-01 17:24 169 查看
E - 尤文图斯
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
2147

Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one
people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?



Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.



Output

If kiki wins the game printf "Wonderful!", else "What a pity!".



Sample Input

5 3
5 4
6 6
0 0




Sample Output

What a pity!
Wonderful!
Wonderful!


所谓的NP就是玩家每次走都有两种可能必胜和必败 P->败,N->胜(是指下一个人的状态)。

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int n,m,i,j;
    ios::sync_with_stdio(false);
    while(cin>>n>>m&&n&&m)
    {
         if(n%2!=0&&m%2!=0) 
         puts("What a pity!");
        else
       printf("Wonderful!\n");
    }
    return 0;
}


然后根据经过一步操作可到达必败状态的都是必胜状态,下一步操作都是必胜状态,那么这步操作时必败状态的原则一步步的去画表格就可以了。

P
这是7*7的表格,如图1,7位置为P。
由于1,6和2,7位置只能向1,7位置移动,所以1,6与2,7为N。

N
PN
同理,第1列和第7行就可以填充完毕。

P
N
P
N
P
N
PNPNPNP
再反观2,6位置,作为2,6位置上的人,想赢得这场比赛,所以肯定会向1,7移动,因此2,6也是N

P
N
P
N
P
NN
PNPNPNP
每个位置上,都会向赢比赛的趋向走,所以剩余各个点的P、N都可以填充完毕

PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP
此图填完,可以找到规律:
只有在行列数均为奇数时,为P,其他情况均为N。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: