您的位置:首页 > 其它

HDU 1213 How Many Tables

2015-08-01 08:48 387 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18365    Accepted Submission(s): 9080


[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

 

#include<stdio.h>
#include<string.h>
int root[30005];
int t[30005];
int find(int x)
{
int i=x;
while(i!=root[i])
i=root[i];
int j=x;
while(j!=root[j])
{
root[j]=i;
j=root[j];
}
return i;

}

void com(int x,int y)
{
int p1,p2;
p1=find(x);
p2=find(y);
if(p1!=p2)
{
if(t[p1]<t[p2])
{
root[p1]=p2;
t[p2]+=t[p1]+1;
t[p1]=0;
}
else
{
root[p2]=p1;
t[p1]+=t[p2]+1;
t[p2]=0;
}

}
}
int main()
{
int p1,p2,m,n,i,max,x;
scanf("%d",&x);
while(x--)
{
scanf("%d %d",&n,&m);
for(i=1;i<=n;i++)
root[i]=i;
memset(t,0,sizeof(t));
while(m--)
{
scanf("%d %d",&p1,&p2);
com(p1,p2);
}
max=n;
for(i=1;i<=n;i++)
{
//        printf("%d ",t[i]);
if(t[i]!=0) max-=t[i];
}
printf("%d\n",max);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: