您的位置:首页 > 其它

HDU 1232 畅通工程

2015-08-01 08:46 344 查看
<div><h1 style="COLOR: #1a5cc8">畅通工程</h1><span size="+0" style=""><strong><span style="font-size: 12px; font-family: Arial; color: green;">Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37759    Accepted Submission(s): 19999
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">对每个测试用例,在1行里输出最少还需要建设的道路数目。
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0</div>


 

[align=left]Sample Output[/align]

1
0
2
998

HintHint
Huge input, scanf is recommended.



</pre><pre name="code" class="objc">
#include<stdio.h>
int root[1005];
int t[1005];
int find(int x)
{
int i=x;
while(i!=root[i])
i=root[i];
int j=x;
while(j!=root[j])
{
root[j]=i;
j=root[j];
}
return i;

}

void com(int x,int y,int *num)
{
int p1,p2;
p1=find(x);
p2=find(y);
if(p1!=p2)
{
root[p1]=p2;
(*num)--;
}
}
int main()
{
int num,p1,p2,m,n,i;
while(scanf("%d",&n)!=EOF)
{
if(n==0) return 0;
for(i=1;i<=n;i++)
root[i]=i;
num=n-1;
scanf("%d",&m);
while(m--)
{
scanf("%d %d",&p1,&p2);
com(p1,p2,&num);
}
printf("%d\n",num);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: