您的位置:首页 > 其它

PAT (Advanced Level) 1093. Count PAT's (25) 一维动态规划

2015-07-31 15:26 351 查看
The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT

Sample Output:
2

计算有多少对PAT,只要一遍扫描即可,O(N)。用一个变量记录当前位置之前有多少对PA,这样遇到T的时候前面的PA数目就是新增的PAT数目。由于遇到A的时候PA的数目可能会增加,还需要用一个变量记录当前位置之前有多少个P,遇到A的时候前面P的数目就是新增的PA数目。

用long long记录总数避免溢出。
/*2015.7.31cyq*/
#include <iostream>
#include <vector>
#include <string>
using namespace std;

int main(){
string s;
cin>>s;
long long count=0;//总PAT数
int PA=0;  //前面的PA数目
int P=0;   //前面的P数目
int n=s.size();
for(int i=0;i<n;i++){
if(s[i]=='T')
count+=PA;
else if(s[i]=='A')
PA+=P;
else if(s[i]=='P')
P++;
}
cout<<count%1000000007;
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: