您的位置:首页 > 大数据 > 人工智能

HDU 5319_Painter

2015-07-31 10:28 369 查看
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 898    Accepted Submission(s): 410


Problem Description

Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally,
so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue,
it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.

 

Input

The first line is an integer T describe the number of test cases.

Each test case begins with an integer number n describe the number of rows of the drawing board.

Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.

1<=n<=50

The number of column of the rectangle is also less than 50.

Output

Output an integer as described in the problem description.

 

Output

Output an integer as described in the problem description.

 

Sample Input

2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR

 

Sample Output

3
6

题目意思是一个画家在画画,如果要画红色,就是“ \ ”,如果是蓝色,就是“ / “ ,如果又画了红色,又画了蓝色,方格中就是G,给出最终的样子,问你要画多少次才能画出来,每次画的长度可以不同。

当时做这道题时没看懂题,以为可以随便乱画,后来才发现是有规律的,做法就是从头扫到底,如果遇到R,就往右下角扫斜线,如果遇到点,就停止,然后把每个扫到的R都变为点,把每个扫到的G都变为B,如果遇到B,则处理的方法类似,这样就不会有重复的了。

P.S. 这道题给出的n是指方格的高度,即x,并没有给出y是多大,所以y还要通过判定输入的字符串的长度来确定

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
char a[110][110];
int main()
{
int t;
cin>>t;
while(t--)
{
int n;
int len=0;
scanf("%d",&n);
getchar();
for(int i=0;i<n;i++)
{
gets(a[i]);
}
int ans=0;
int nut=0;
int sum=0;
len=strlen(a[0]);
for(int i=0;i<n;i++)
{
for(int j=0;j<len;j++)
{
if(a[i][j]=='R'||a[i][j]=='G')
{
sum++;
ans=i;
nut=j;
while(ans<n&&nut<len)
{
if(a[ans][nut]=='B'||a[ans][nut]=='.')  break;
if(a[ans][nut]=='R')  a[ans][nut]='.';
else if(a[ans][nut]=='G')  a[ans][nut]='B';
ans++;
nut++;
}
}
if(a[i][j]=='B'||a[i][j]=='G')
{
sum++;
ans=i;
nut=j;
while(ans<n&&nut>=0)
{
if(a[ans][nut]=='R'||a[ans][nut]=='.')  break;
if(a[ans][nut]=='B')  a[ans][nut]='.';
else if(a[ans][nut]=='G')  a[ans][nut]='R';
ans++;
nut--;
}
}
}
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU