您的位置:首页 > 其它

HD2141 Can you find it? 【二分法求解】

2015-07-30 21:41 183 查看

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 17492 Accepted Submission(s): 4422



[align=left]Problem Description[/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

[align=left]Input[/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent
the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

[align=left]Output[/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

[align=left]Sample Input[/align]

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10


[align=left]Sample Output[/align]

Case 1:
NO
YES
NO**************************************************************************************************************************************************************************************************************AC代码[code]//不能用三层for循环来解,这样容易超时,用二分法。
#include<stdio.h>
#include<algorithm>
#include<iostream>
#define max 550
using namespace std;
int L[max],M[max],N[max],s[max*max];
int a,b,c;
int main()
{
int k,j,x,p=1;
while(scanf("%d %d %d",&a,&b,&c)!=EOF)
{
k=0;
for(int i=0;i<a;i++)
scanf("%d",&L[i]);
for(int i=0;i<b;i++)
scanf("%d",&M[i]);
for(int i=0;i<c;i++)
scanf("%d",&N[i]);
for(int i=0;i<a;i++)
{
for(int j=0;j<b;j++)
{

s[k++]=L[i]+M[j];
}
}
sort(s,s+a*b);//用二分法必须是有序的一些数,所以必须排序。
int flag;
scanf("%d",&k);
//int p=1;
printf("Case %d:\n",p++);
while(k--)
{
flag=0;
scanf("%d",&x);
for(int i=0;i<c;i++)
{
if((binary_search(s,s+a*b,x-N[i]))!=0)//在数组中以二分法检索的方式查找,若在数组(要求数组元素非递减)中查找到x-N[i]元素则返回其下标,若查找不到则返回值为假。

{
flag=1;
}
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: