您的位置:首页 > 其它

poj 2632 Crashing Robots

2015-07-30 21:26 387 查看
Description
In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots
occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the
robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.

A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in
the NS-direction.

The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.

Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.



Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order.

An instruction has the following format:

< robot #> < action> < repeat>

Where is one of
L: turn left 90 degrees,

R: turn right 90 degrees, or

F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
Output one line for each test case:
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)

Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.

OK, if no crashing occurs.

Only the first crash is to be reported.
Sample Input
4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output
Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct node
{
int x,y;
int dir;
} r[110];

int Map[110][110];
int a,b;
int flag;
int Dir[][2] = {{0,1},{1,0},{0,-1},{-1,0}};

void FF(int i,int step)
{
int x,y,d;
x = r[i].x;
y = r[i].y;
d = r[i].dir;
Map[x][y] = 0;
while(step--)
{
x += Dir[d][0];
y += Dir[d][1];
if(x < 1 || x > a || y < 1 || y > b)
{
printf("Robot %d crashes into the wall\n",i);
flag = true;
return ;
}
if(Map[x][y])
{
printf("Robot %d crashes into robot %d\n",i,Map[x][y]);
flag = true;
return ;
}
}
Map[x][y] = i;
r[i].x = x;
r[i].y = y;
return ;
}

void AA(int i,char ch,int step)
{
switch(ch)
{
case 'F':
FF(i,step);
break;
case 'L':
r[i].dir = (r[i].dir - step%4 + 4)%4;
break;
case 'R':
r[i].dir = (r[i].dir + step%4)%4;
break;
}
}

int main()
{
// freopen("in.txt","r",stdin);
int T;
cin>>T;
while(T--)
{
memset(Map,0,sizeof(Map));
int n,m;
cin>>a>>b>>n>>m;
for(int i=1; i<=n; i++)
{
char ch;
cin>>r[i].x>>r[i].y>>ch;
switch(ch)
{
case 'N':
r[i].dir = 0;
break;
case 'E':
r[i].dir = 1;
break;
case 'S':
r[i].dir = 2;
break;
case 'W':
r[i].dir = 3;
break;
}
Map[r[i].x][r[i].y] = i;
}
flag = false;
while(m--)
{
char ch;
int id,step;
cin>>id>>ch>>step;
if(flag == false)
AA(id,ch,step);
}
if(!flag)
cout<<"OK"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: