您的位置:首页 > 其它

HDOJ 1551 Cable master(二分查找)

2015-07-30 21:24 239 查看

Cable master

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2513 Accepted Submission(s): 940



Problem Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect
computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from
it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants
as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not
known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.



Input
The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K
≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths
in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0's.



Output
For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written
with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).



Sample Input
4 11
8.02
7.43
4.57
5.39
0 0




Sample Output
2.00




题意:有n段长度不同的光缆,分成k段长度相同的光缆,问分割后的每根光缆的长度

注:hdu的题于poj上的题有差别,要仔细看题。



代码如下:



#include<cstdio>
int n,k;
double a[10010];

int find(double x)
{
	int i,sum=0;
	for(i=0;i<n;i++)
	   sum+=(int)(a[i]/x);//注意要取整 
	if(sum>=k)
	   return 1;
	 else
	   return 0;	
}

int main()
{
	int i;
	double L,R,mid;
	while(scanf("%d%d",&n,&k)&&n||k)
	{
		for(i=0;i<n;i++)
		  scanf("%lf",&a[i]);
		L=1;R=10000000;//题中说分割后的光缆长度至少1厘米,但不超过100千米 ,这里全转化为厘米单位 
		while(R-L>1e-8)
		{
			mid=(L+R)/2;
			if(find(mid))
			   L=mid;
			else
			   R=mid;
		}
		printf("%.2lf\n",mid);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: