您的位置:首页 > 其它

HDOJ 1969 Pie(二分查找)

2015-08-03 16:22 267 查看

Pie

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6553 Accepted Submission(s): 2473



Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them
gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.



Input
One line with a positive integer: the number of test cases. Then for each test case:

---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.



Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute
error of at most 10^(-3).


Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2




Sample Output
25.1327
3.1416
50.2655





二分查找,看懂题目意思,算出每块pie的体积,最后用二分查找就可以得到每个人分到的pie体积。



注意:这里圆周率(pi)的值直接用反余弦表示,PI=acos(-1.0)



代码如下:



<span style="font-size:12px;">#include<cstdio>
#include<cmath>
double PI=acos(-1.0);
int n,f,r;
double v[10010];

int find(double x)
{
	int i,sum=0;
	for(i=0;i<n;i++)
	   sum+=(int)(v[i]/(x*1.0));
	if(sum>=f+1)//还要算上自己 
	  return 1;
	else
	  return 0;
}

int main()
{
	int t,i;
	double R,L,mid;
	scanf("%d",&t);
	while(t--)
    {
		scanf("%d%d",&n,&f);
		for(i=0;i<n;i++)
		{
			scanf("%d",&r);
			v[i]=PI*r*r*1.0;
		}
		R=320000000;
		L=0.0;//一定要赋值为0,WA了好多次 
		while(R-L>1e-6)
		{
			mid=(R+L)/2.0;
			if(find(mid))
			  L=mid;
			else
			  R=mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: