您的位置:首页 > 产品设计 > UI/UE

hdu-1509 Windows Message Queue(优先队列)

2015-07-28 21:23 239 查看

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4459    Accepted Submission(s): 1776


[align=left]Problem Description[/align]
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.
 

[align=left]Input[/align]
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter
and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

[align=left]Output[/align]
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

[align=left]Sample Input[/align]

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

 

[align=left]Sample Output[/align]

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

# include<stdio.h>
# include<queue>
# include<algorithm>
# include<string.h>
using namespace std;
struct win
{
char name[50];
int id,val,parameter;
friend bool operator < (win a,win b)
{
if(a.val==b.val)
return b.id<a.id;
return b.val<a.val;
}

}tmp;
priority_queue<win> q;
int main()
{
char a[50];int k=0;
while(~scanf("%s",a))
{
if(a[0]=='G')
{
if(q.empty())
puts("EMPTY QUEUE!");
else
{
tmp=q.top();
q.pop();
printf("%s %d\n",tmp.name,tmp.parameter );
}
}
else
{
scanf("%s%d%d",tmp.name ,&tmp.parameter,&tmp.val );
tmp.id=++k;
q.push(tmp);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: