您的位置:首页 > 其它

2015 多校联赛 ——HDU5319(模拟)

2015-07-28 20:34 288 查看


Painter

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 895 Accepted Submission(s): 408



Problem Description

Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally,
so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue,
it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.



Input

The first line is an integer T describe the number of test cases.

Each test case begins with an integer number n describe the number of rows of the drawing board.

Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.

1<=n<=50

The number of column of the rectangle is also less than 50.

Output

Output an integer as described in the problem description.



Output

Output an integer as described in the problem description.



Sample Input

2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR




Sample Output

3
6




Author

ZSTU



Source

2015 Multi-University Training Contest 3

按照45度刷墙,红色的从左上 ->右下,蓝色从右上->左下,一种颜色对一个点只能刷一次,红 + 蓝 ->绿

模拟即过。

(论英语的重要性!! 看半天才懂什么意思)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stdlib.h>
using namespace std;

char Map[60][60];

int main()
{
    int n,T;
//    freopen("4.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
            scanf("%s",Map[i]);
        int i,j;
        int tot= 0;
        int len = strlen(Map[0]);
        for(i = 0; i < n; i++)
            for(j = 0; j < len; j++)
            {
                if(Map[i][j] == 'R' ||  Map[i][j] == 'r')
                {
                    tot++;
                    Map[i][j] = '.';
                    for(int k = 1; k + i < n && j + k < len; k++)
                    {
                        if(Map[i+k][j+k] == 'R' || Map[i+k][j+k] == 'r')
                            Map[i+k][j+k] = '.';

                        else if(Map[i+k][j+k] == 'G')
                            Map[i+k][j+k] = 'b';

                        else
                            break;
                    }
                }
                if(Map[i][j] == 'B' ||  Map[i][j] == 'b')
                {
                    tot++;
                    Map[i][j] = '.';
                    for(int k = 1; k + i < n && j - k >= 0; k++)
                    {
                        if(Map[i+k][j-k] == 'B' || Map[i+k][j-k] == 'b')
                            Map[i+k][j-k] = '.';

                        else if(Map[i+k][j-k] == 'G')
                            Map[i+k][j-k] = 'r';

                        else
                            break;
                    }
                }
                if(Map[i][j] == 'G')
                {
                    tot+=2;
                    Map[i][j] = '.';
                    for(int k = 1; k + i < n && j - k >= 0; k++)
                    {
                        if(Map[i+k][j-k] == 'G')
                            Map[i+k][j-k] = 'r';
                        else if(Map[i+k][j-k] == 'B' || Map[i+k][j-k] == 'b')
                            Map[i+k][j-k] = '.';
                        else
                            break;
                    }
                    for(int k = 1; k + i < n && j + k < len ; k++)
                    {
                        if(Map[i+k][j+k] == 'G')
                            Map[i+k][j+k] = 'b';
                        else if(Map[i+k][j+k] == 'R' || Map[i+k][j+k] == 'r')
                            Map[i+k][j+k] = '.';
                        else
                            break;
                    }
                }
            }
        printf("%d\n",tot);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: