您的位置:首页 > 其它

2015 多校联赛 ——HDU5316(线段树)

2015-07-29 16:39 302 查看
Fantasy magicians usually gain their ability through one of three usual methods: possessing it as an innate talent, gaining it through study and practice, or receiving it from another being, often a god, spirit, or demon of some sort. Some wizards are depicted
as having a special gift which sets them apart from the vast majority of characters in fantasy worlds who are unable to learn magic.

Magicians, sorcerers, wizards, magi, and practitioners of magic by other titles have appeared in myths, folktales, and literature throughout recorded history, with fantasy works drawing from this background.

In medieval chivalric romance, the wizard often appears as a wise old man and acts as a mentor, with Merlin from the King Arthur stories representing a prime example. Other magicians can appear as villains, hostile to the hero.



Mr. Zstu is a magician, he has many elves like dobby, each of which has a magic power (maybe negative). One day, Mr. Zstu want to test his ability of doing some magic. He made the elves stand in a straight line, from position 1 to position n, and he used two
kinds of magic, Change magic and Query Magic, the first is to change an elf’s power, the second is get the maximum sum of beautiful subsequence of a given interval. A beautiful subsequence is a subsequence that all the adjacent pairs of elves in the sequence
have a different parity of position. Can you do the same thing as Mr. Zstu ?



Input

The first line is an integer T represent the number of test cases.

Each of the test case begins with two integers n, m represent the number of elves and the number of time that Mr. Zstu used his magic.

(n,m <= 100000)

The next line has n integers represent elves’ magic power, magic power is between -1000000000 and 1000000000.

Followed m lines, each line has three integers like

type a b describe a magic.

If type equals 0, you should output the maximum sum of beautiful subsequence of interval [a,b].(1 <= a <= b <= n)

If type equals 1, you should change the magic power of the elf at position a to b.(1 <= a <= n, 1 <= b <= 1e9)



Output

For each 0 type query, output the corresponding answer.



Sample Input

1
1 1
1
0 1 1




Sample Output

1




Source

2015 Multi-University Training Contest 3

// 以前没专门学习过线段树,所有是参考别人代码写出了的(表示最初并没有看懂题意 OoO!)

题意:有n个数,两个操作,0操作,输出l到r ,所有奇偶交替的子序列中,值的最大和。 1操作是把a位置的数改成b。

用oo代表偶始偶终:oo可以由oj oo合成,oo jo 合成。其他与此类似

#include <iostream>
#include <cstdio>
#include <cstring>
typedef long long ll;
using namespace std;
const int n= 100010;
const ll INF = 1000000000000000000;

struct pnode
{
    int l,r;
    ll jj,jo,oj,oo;
} node[n<<2];
ll a
;

ll max(ll x, ll y)
{
    if(x < y)
        return y;
    return x;
}

void work(int i)
{
    int lc = i << 1;
    int rc = lc | 1;

    node[i].jj = max(node[lc].jj,node[rc].jj);
    node[i].jj = max(node[i].jj,node[lc].jj+node[rc].oj);
    node[i].jj = max(node[i].jj,node[lc].jo+node[rc].jj);

    node[i].oj = max(node[lc].oj,node[rc].oj);
    node[i].oj = max(node[i].oj,node[lc].oo+node[rc].jj);
    node[i].oj = max(node[i].oj,node[lc].oj+node[rc].oj);

    node[i].jo = max(node[lc].jo,node[rc].jo);
    node[i].jo = max(node[i].jo,node[lc].jj+node[rc].oo);
    node[i].jo = max(node[i].jo,node[lc].jo+node[rc].jo);

    node[i].oo = max(node[lc].oo,node[rc].oo);
    node[i].oo = max(node[i].oo,node[lc].oj+node[rc].oo);
    node[i].oo = max(node[i].oo,node[lc].oo+node[rc].jo);
}
void build(int i,int l,int r)
{
    node[i].l = l;
    node[i].r = r;

    if(l == r)
    {
        if(l % 2)
        {
            node[i].jj = a[l];
            node[i].jo = node[i].oj = node[i].oo = -INF;
        }
        else
        {
            node[i].oo = a[l];
            node[i].jo = node[i].oj = node[i].jj = -INF;
        }
        return;
    }

    build(i << 1,l ,(l+r)/2);
    build(i << 1 | 1, (l+r)/2 + 1,r);

    work(i);
}

void update(int i,int pos,int val)
{
    if(node[i].l == pos && node[i].r == pos)
    {
        if(pos % 2)
        {
            node[i].jj = val;
        }
        else
        {
            node[i].oo = val;
        }
        return;
    }

    int mid = (node[i].l + node[i].r)/2;
    if(pos <= mid)
        update(i << 1,pos, val);
    else
        update(i << 1 | 1,pos, val);

    work(i);
}

pnode query(int i,int l,int r)
{
    if(node[i].l == l && node[i].r == r) return node[i];

    int lc = i << 1;
    int rc = lc+1;
    int mid =  ( node[i].l + node[i].r )/2;

    if(r <= mid )
        return query(lc,l,r);
    else if(l > mid)
        return query(rc,l,r);
    else
    {
        pnode ln = query( lc, l, mid ), rn = query( rc, mid + 1, r ), res;
        res.jj = max( ln.jj, rn.jj );
        res.jj = max( res.jj, ln.jj + rn.oj );
        res.jj = max( res.jj, ln.jo + rn.jj );
        res.jo = max( ln.jo, rn.jo );
        res.jo = max( res.jo, ln.jj + rn.oo );
        res.jo = max( res.jo, ln.jo + rn.jo );
        res.oj = max( ln.oj, rn.oj );
        res.oj = max( res.oj, ln.oj + rn.oj );
        res.oj = max( res.oj, ln.oo + rn.jj );
        res.oo = max( ln.oo, rn.oo );
        res.oo = max( res.oo, ln.oo + rn.jo );
        res.oo = max( res.oo, ln.oj + rn.oo );
        return res;
    }
}

int main ()
{

    int t,m,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&k);

        for(int i = 1; i <= m; i++)
            scanf("%I64d",&a[i]);

        build(1,1,m);

        while(k--)
        {
            int op;
            scanf("%d", &op);
            if ( op == 0 )

            {
                int l, r;
                scanf("%d%d", &l, &r);
                pnode nn = query( 1, l, r );
                ll ans = nn.jj;
                ans = max( ans, nn.jo );
                ans = max( ans, nn.oj );
                ans = max( ans, nn.oo );
                printf("%I64d\n", ans);

            }
            else if ( op == 1 )

            {
                int pos, val;
                scanf("%d%d", &pos, &val);
                update( 1, pos, val );
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: