您的位置:首页 > 其它

ZOJ 1004 Anagrams by Stack

2015-07-28 19:26 435 查看
C - Anagrams by Stack
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld
& %llu
Submit Status Practice ZOJ
1004

Description

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each
pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and

Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed
and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o ois valid, but
i i ois not (it's too short), neither is
i i o o o i(there's an illegal pop of an empty stack)
Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o oproduce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs
of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice



Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[ ][
i i o i o i o o
]


由于需要字典序,故dfs时先执行进栈操作i,再o。
这题关键主要在于下面注释的细节。

#include <iostream>
#include <cstdio>
#include<cstring>
using namespace std;

char c[10000],s[10000],t[10000],a[10000];
int l,in;
void dfs(int k,int w,int top,int in){
if (k==2*l){
int i;
for (i=1;i<=2*l;i++) cout<<c[i]<<' ';
cout<<endl;
} else {
if (in<l){//控制进栈总次数
k++;
c[k]='i';
top++;
a[top]=s[in];
in++;
dfs(k,w,top,in);
in--;
c[k]='#';
a[top]=0;
top--;
k--;
}
if (top<0) return;//无法执行出栈操作
if (a[top]==t[w]){//栈顶元素满足要求时执行出栈操作
k++;
char ch;
c[k]='o';
ch=a[top];
a[top]=0;
top--;
dfs(k,w+1,top,in);
top++;
a[top]=ch;//回溯注意还原栈的状态
c[k]='#';
k--;
}
}
}
int main()
{
while (cin>>s>>t){
cout<<'['<<endl;
l=strlen(s);
in=0;
if (strlen(s)==strlen(t)) {
dfs(0,0,-1,0);
}
cout<<']'<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: