您的位置:首页 > 大数据 > 人工智能

Acboy needs your help again!

2015-07-28 18:47 429 查看

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4439    Accepted Submission(s): 2265


[align=left]Problem Description[/align]
ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

 

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.
 

 

[align=left]Output[/align]
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

 

[align=left]Sample Input[/align]

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

 

[align=left]Sample Output[/align]

1
2
2
1
1
2
None
2
3

 
 
这道题有两种方法可以解决~
方法一:数组
#include<stdio.h>
#include<string.h>
int c[10000],b[10000];
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int m,t,j,j1,j2;
char a[5],s[5];
scanf("%d%s",&m,a);
if(!strcmp(a,"FILO"))
{
j=j1=j2=0;
while(m--)
{
scanf("%s",s);
if(!strcmp(s,"IN"))
{
scanf("%d",&t);
c[j++]=t;
j2++;
}
else
{
if(j==0)
printf("None\n");
else
{
printf("%d\n",c[j-1]);
j--;
}
}
}
}
else if(!strcmp(a,"FIFO"))
{
j=j1=j2=0;
while(m--)
{
scanf("%s",s);
if(!strcmp(s,"IN"))
{
scanf("%d",&t);
b[j++]=t;
}
else
{
if(j1>=j)
printf("None\n");
else
{
printf("%d\n",b[j1++]);
}
}
}
}
}
return 0;
}

方法二:栈和队列~~
#include<stdio.h>
#include<queue>
#include<string.h>
#include<stack>
#include<iostream>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
char a[10];
int m;
scanf("%d%s",&m,a);
if(!strcmp(a,"FIFO"))
{
queue<int> q;
while(m--)
{
char s[10];
scanf("%s",s);
if(!strcmp(s,"IN"))
{
int b;
scanf("%d\n",&b);
q.push(b);
}
else
{
if(q.empty())
printf("None\n");
else
{
printf("%d\n",q.front());
q.pop();
}
}
}
}
else
{
stack<int>w;
while(m--)
{
char s[10];
scanf("%s",s);
if(!strcmp(s,"IN"))
{
int b;
scanf("%d",&b);
w.push(b);
}
else
{
if(w.empty())
printf("None\n");
else
{
printf("%d\n",w.top());
w.pop();
}
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: