您的位置:首页 > 其它

HDOJ 4006 The kth great number(优先队列)

2015-07-28 17:52 204 查看

The kth great number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 8253 Accepted Submission(s): 3265



Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is
too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.


Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed
by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.



Output
The output consists of one integer representing the largest number of islands that all lie on one line.



Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q




Sample Output
1
2
3

HintXiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).






超时,跪了!!若用循环法超找到第k大的值,然后再将前面的值再存进去会超时,k值很大,k<=1000000。



解决超时,将队列按小到大的顺序排列,当队列的长度大于k时,则删除对顶元素。这样就使得对顶元素永远是第k大的数。



具体代码如下:



#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int main()
{
	int n,k,a;
	char str[3];
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		priority_queue<int,vector<int>,greater<int> >q;//注意更新队列 
		while(n--)
		{
			scanf("%s",str);
			if(strcmp(str,"I")==0)
			{
				scanf("%d",&a);
				q.push(a);
				if(q.size()>k)
				   q.pop();
			}
			else
				printf("%d\n",q.top());
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: