您的位置:首页 > 产品设计 > UI/UE

01-复杂度2. Maximum Subsequence Sum (25)

2015-07-26 14:51 453 查看
题目来自网易云课堂的《数据结构习题集》

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1,
..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is
{ 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:10 1 4


#include <stdio.h>

int main(void)
{
int K, i, sum = 0, max = 0, begin, end, tmp;
printf("Please input K:");
scanf("%d", &K);
int a;
printf("Please enter in K numbers, split by space:\n");
for(i=0; i<K; ++i)
{
scanf("%d", &a);
if (i == 0)
tmp = a;
if(sum < 0)
{
sum = a;
tmp = a;
}
else
{
sum += a;
}
if(sum > max)
{
begin = tmp;
end = a;
max = sum;
}
}
if(max < 0)
printf("The Maximum Subsequence Sum: 0, begin with %d, end with %d", begin, end);
else
printf("The Maximum Subsequence Sum: %d, begin with %d, end with %d", max, begin, end);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: