您的位置:首页 > 其它

hdoj 2147 kiki's game 【博弈】

2015-07-25 12:42 537 查看

kiki's game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 40000/10000 K (Java/Others)

Total Submission(s): 8005 Accepted Submission(s): 4751

Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one
people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?



Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.



Output
If kiki wins the game printf "Wonderful!", else "What a pity!".



Sample Input
5 3
5 4
6 6
0 0




Sample Output
What a pity!
Wonderful!
Wonderful!




一开始怎么想都感觉不对劲,最后发现自己漏看个条件,可以走左下方!!!

AC代码:判断必胜点

#include <cstdio>
#include <cstring>
int main()
{
	int n, m;
	while(scanf("%d%d", &n, &m), n || m)
	{
		if(n & 1 && m & 1)
		printf("What a pity!\n");
		else
		printf("Wonderful!\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: