您的位置:首页 > 其它

1019. General Palindromic Number (20)

2015-07-25 11:32 351 查看
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1
digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is
non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated
by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0".
Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1


提交代

——————————————

AC代码

#include <iostream>
#include <math.h>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */
#define MAX 1000

int main(int argc, char** argv) {
long long N,b;
int res[MAX]={0},index=0;

//	cin>>N>>b;
scanf("%ld%ld\n",&N,&b);
while(N != 0){
res[index++]=N%b;
N/=b;
}
int i=0,j=index-1;
bool flag=true;
while(i<j){
if(res[i] != res[j]){
flag=false;
break;
}
i++;j--;
}
(flag)?printf("Yes\n"):printf("No\n");
for(i=index-1; i>0; i--){
printf("%d ",res[i]);
}
printf("%d",res[0]);

return 0;
}


刚刚开始的时候,一直有下面错误。

第五个测试点的错误。



主要是因为0的问题。

#include <iostream>
#include <math.h>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */
#define MAX 1000

int main(int argc, char** argv) {
long long N,b;
int res[MAX],index=0;

//	cin>>N>>b;
scanf("%ld %ld",&N,&b);
while(N != 0){
res[index++]=N%b;
N/=b;
}
int i=0,j=index-1;
bool flag=true;
while(i<j){
if(res[i] != res[j]){
flag=false;
break;
}
i++;j--;
}
(flag)?printf("Yes\n"):printf("No\n");
for(i=index-1; i>=0; i--){
printf("%d",res[i]);
(i==0)?printf("\n"):printf(" ");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: