您的位置:首页 > 产品设计 > UI/UE

杭电1047 Integer Inquiry【无限大数和】

2015-07-24 20:14 417 查看
Problem Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)



Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.



Output

Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0




Sample Output

370370367037037036703703703670




//题意是n个大数相加

#include<stdio.h>
#include<string.h>
#define max 1100
char s1[max];
int a[max],b[max];
int main()
{
	int T,i,j,len1;
    scanf("%d",&T);
    while(T--)
    {
    	memset(a,0,sizeof(a));
			
    	while(~scanf("%s",s1))
    	{
    		if(strcmp(s1,"0")==0) break;
    		int len1=strlen(s1);
    		memset(b,0,sizeof(b));	//这里把我坑了n次,每次都要初始化		
			for(j=0,i=len1-1;i>=0;--i,++j)//字符型变整型 
			{
				b[j]=s1[i]-'0';
			}
			for(i=0;i<max;++i)
			{
				a[i]+=b[i];
				if(a[i]>=10)
				{
					a[i]-=10;
					a[i+1]++;
				}
			}
    	}
    	for(i=max-1;i>0;--i)
		{
			if(a[i]!=0) break;
		}
		
		for(j=i;j>=0;--j)
		{
			printf("%d",a[j]);
		}
		printf("\n");
		if(T) printf("\n"); 
    }
    
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: