您的位置:首页 > 其它

PAT (Advanced Level) 1036. Boys vs Girls (25) 结构体排序

2015-07-24 19:43 363 查看
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters
with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM.
If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

结构体排序。

/*2015.7.24cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
#include <string>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct stu{
string name;
string mf;
string id;
int score;
};
bool cmp(const stu &x,const stu &y){
if(x.mf=="F"&&y.mf=="M")
return true;
else if(x.mf=="F"&&y.mf=="F"||x.mf=="M"&&y.mf=="M")
return x.score>y.score;

return false;
}
int main(){
int N;
cin>>N;
vector<stu> a(N);
for(int i=0;i<N;i++){
cin>>a[i].name>>a[i].mf>>a[i].id>>a[i].score;
}
sort(a.begin(),a.end(),cmp);
bool noF=false;
bool noM=false;
if(a[0].mf!="F")
noF=true;
if(a[N-1].mf!="M")
noM=true;
if(noF){
cout<<"Absent"<<endl;
if(noM)
cout<<"Absent"<<endl;
else
cout<<a[N-1].name<<" "<<a[N-1].id<<endl;
cout<<"NA"<<endl;
}else{
cout<<a[0].name<<" "<<a[0].id<<endl;
if(noM){
cout<<"Absent"<<endl;
cout<<"NA"<<endl;
}else{
cout<<a[N-1].name<<" "<<a[N-1].id<<endl;
cout<<a[0].score-a[N-1].score<<endl;
}
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: