您的位置:首页 > 其它

hdu An easy problem (背包)

2015-07-24 19:39 295 查看


Problem Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..



One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?


Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).


Output

For each case, output the number of ways in one line.


Sample Input

2
1
3



Sample Output

0
1
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int t,i,m,sum;
__int64 n;
while(scanf("%d",&t)!=EOF){
while(t--){
sum=0;
scanf("%I64d",&n);
n+=1;
m=sqrt(n);
for(i=2;i<=m;i++) if(n%i==0) sum++;
printf("%d\n",sum);
}
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: