您的位置:首页 > 其它

hdoj.1325 Is It A Tree?[【并查集】 2015/07/24

2015-07-24 16:20 197 查看

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17468 Accepted Submission(s): 3929

[align=left]Problem Description[/align]
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

[align=left]Input[/align]
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist
of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

[align=left]Output[/align]
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

[align=left]Sample Input[/align]

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


[align=left]Sample Output[/align]

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


[align=left]Source[/align]
North Central North America 1997
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define maxn 100010
int parent[maxn],a,b,fx,fy,num[maxn];

void init(){
for( int i = 0 ; i < maxn ; ++i ){
parent[i] = i;
}
}

int find_parent(int x){
while( parent[x] != x )
x=parent[x];
return x ;
}

bool join(int a,int b){
while( parent[a] != b ){
if( parent[a] == a ) return true;
a = parent[a];
}
return false;
}

int main(){
int sss = 1;
while( scanf("%d %d",&a,&b) ){
if( a < 0 || b < 0 ) break;
if( a == 0 && b == 0 ){
printf("Case %d is a tree.\n",sss++);
continue;
}
memset(num,0,sizeof(num));
num[a] = 1;
num[b] = 1;
init();
bool flag = false;
if( a == b ) flag = true;
parent[b] = a;
while( scanf("%d %d",&a,&b) ){
if( a == 0 && b == 0 ) break;
if( a == b ) flag = true;
num[a] = 1;
num[b] = 1;
if( parent[b] != b ) flag = true;
if( join(a,b) )
parent[b] = a;
else flag = true;
}
int root = -1;
for( int i = 1 ; i < maxn ; ++i )
if( num[i] ){
int ret = find_parent(i);
if( ret != root ){
if( root == -1 )
root = ret;
else{
flag = true;
break;
}
}
}
printf("Case %d ",sss++);
if( flag )
printf("is not a tree.\n");
else printf("is a tree.\n");
}
return 0;
}
注:题目比较坑。。。。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: