您的位置:首页 > 其它

Friends(DFS+剪枝)

2015-07-24 11:41 211 查看
Link:http://acm.hdu.edu.cn/showproblem.php?pid=5305


Friends

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 713 Accepted Submission(s): 335



Problem Description

There are n people
and m pairs
of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people
wants to have the same number of online and offline friends (i.e. If one person has x onine
friends, he or she must have x offline
friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements.



Input

The first line of the input is a single integer T (T=100),
indicating the number of testcases.

For each testcase, the first line contains two integers n (1≤n≤8) and m (0≤m≤n(n−1)2),
indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines
contains two numbers x and y,
which mean x and y are
friends. It is guaranteed that x≠y and
every friend relationship will appear at most once.



Output

For each testcase, print one number indicating the answer.



Sample Input

2
3 3
1 2
2 3
3 1
4 4
1 2
2 3
3 4
4 1




Sample Output

0
2




Source

2015 Multi-University Training Contest 2



AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
#include<cmath>
#define LL long long
#define MAXN 222
using namespace std;
int n,m,l,r,i,j,x,y;
int a[MAXN],F[11][2];
int size[MAXN];
int cnt;
const int MOD=1e9+7;
vector<int>vec[MAXN];
void dfs(int idx)
{
    if(idx==m+1)
    {
        for(i=1;i<=n;i++)
        {
            if(F[i][0]!=F[i][1])
                break;
        }
        if(i==n+1)
            cnt++;
        return;
    }
    for(int c=0;c<=1;c++)
    {
        F[vec[idx][0]][c]++;
        F[vec[idx][1]][c]++;
        if(F[vec[idx][0]][c]>(size[vec[idx][0]]/2)||F[vec[idx][1]][c]>(size[vec[idx][1]]/2))
        {
            F[vec[idx][0]][c]--;
            F[vec[idx][1]][c]--;
            continue;
        }
        dfs(idx+1);
        F[vec[idx][0]][c]--;
        F[vec[idx][1]][c]--;
    }
    return;    
 } 
int main()
{
    int T;
    bool flag;
    while(scanf("%d",&T)!=EOF)
    {        
        while(T--)
        {
            flag = false;
            memset(size,0,sizeof(size));
            scanf("%d%d",&n,&m);
                for(i=1;i<=m;i++)
                    vec[i].clear();
                for(i=1;i<=m;i++)
                {
                    scanf("%d%d",&x,&y);
                    vec[i].push_back(x);
                    vec[i].push_back(y);
                    size[x]++;
                    size[y]++;
                }
                cnt=0;
                for(i=1;i<=n;i++)
                {
                    F[i][0]=0;
                    F[i][1]=0;
                }
                for(i=1;i<=n;i++)
                {
                    if(size[i] % 2 != 0)
                    {
                        flag = true;
                        break;
                    }
                }
                if(flag == true)
                {
                    printf("0\n");
                }
                else{
                    dfs(1);
                    printf("%d\n",cnt);
                }        
        }
    }
    return 0;
 }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: