您的位置:首页 > 其它

HDU 1020 Encoding

2015-07-21 22:50 465 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32652 Accepted Submission(s): 14505


[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

[align=left]Input[/align]
The
first line contains an integer N (1 <= N <= 100) which indicates
the number of test cases. The next N lines contain N strings. Each
string consists of only 'A' - 'Z' and the length is less than 10000.

[align=left]Output[/align]
For each test case, output the encoded string in a line.

[align=left]Sample Input[/align]

2
ABC
ABBCCC

[align=left]Sample Output[/align]

ABC
A2B3C

[align=left]Author[/align]
ZHANG Zheng

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you: 1008 1004 1019 1021 1062

#include<queue>
#include<map>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 100005
int n,i,j,ma,cnt;
char str
;
int main()
{
int t;cin>>t;
while(t--)
{
cnt=0;
scanf("%s",str);
for(int i=0;str[i];i++)
{
if(str[i]==str[i+1])
{
cnt++;
continue;
}
if(cnt)
{
printf("%d%c",cnt+1,str[i]);
cnt=0;
continue;
}
printf("%c",str[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: