您的位置:首页 > 其它

HDU 1040 As Easy As A+B [补]

2015-07-22 17:23 399 查看
今天去老校区找她,不想带电脑了,所以没时间A题了

/*******************************************************************/

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45926 Accepted Submission(s): 19620


[align=left]Problem Description[/align]
These
days, I am thinking about a question, how can I get a problem as easy
as A+B? It is fairly difficulty to do such a thing. Of course, I got it
after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

[align=left]Input[/align]
Input
contains multiple test cases. The first line of the input is a single
integer T which is the number of test cases. T test cases follow. Each
test case contains an integer N (1<=N<=1000 the number of integers
to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

[align=left]Output[/align]
For each case, print the sorting result, and one line one case.

[align=left]Sample Input[/align]

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

[align=left]Sample Output[/align]

1 2 3
1 2 3 4 5 6 7 8 9

[align=left]Author[/align]
lcy

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1096 1090 1004 1029 1091

#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 111555

int a
,n;

int main()
{
int t;cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)cin>>a[i];
sort(a,a+n);
int i;
for(i=0;i<n-1;i++)
printf("%d ",a[i]);
printf("%d\n",a[i]);

}

return 0;

}

//freopen("1.txt", "r", stdin);
//freopen("2.txt", "w", stdout);
//**************************************
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: