您的位置:首页 > 其它

poj 2366 Sacrament of the sum

2015-07-21 20:43 405 查看

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description

— The Brother of mine, the Head of Monastic Order wants to know tomorrow about the results long-term researches. He wants to see neither more nor less than the Summering Machine! Even moreover, he wants our Machine — only a machine
— to demonstrate its comprehension of the Sacrament of the Sum as deeply as it is possible. He wants our Machine to find two numbers that give the sum equal to the Sacred Number 10 000.

— Tsh-sh-sh! This is madness that borders on blasphemy! How can the Machine calculate the Sacred Number? Twenty seven years we work on it, but we've could teach it to tell if the sum of two introduced numbers greater or lower than 10 000. Can an ordinary mortal
find two numbers that there sum will be equal to 10 000?

— But we'll have to do it with the help of our Machine, even if it is not capable. Otherwise we'll have... let's say, big problems, if it is possible to call boiling oil like this. However, I have an idea. Do you remember, last week we've entered two numbers
-7 and 13 into the Machine, and it answered that their sum is lower than 10 000. I don't know how to check this, but nothing's left for us than to believe to the fruit of our work. Let's enter now a greater number than -7 and start up the Machine again. We'll
do like this again and again until we find a number that being added to 13 will give us 10 000. The only thing we are to do is to prepare an ascending list of numbers.

— I don't believe in this... Let's start with the sum that is obviously greater than the Sacred Number and we'll decrease one of the summand. So we have more chances to avoid boilin... big problems.

Haven't come to an agreement, the Brothers went away to their cells. By next day everyone of them has prepared a list of numbers that, to his opinion, could save them... Can both of the lists save them together?

Your program should decide, if it is possible to choose from two lists of integers such two numbers that their sum would be equal to 10 000.

Input

You are given both of these lists one by one. Format of each of these lists is as follows: in the first line of the list the quantity of numbers Ni of the i-th list is written. Further there is an i-th list of numbers each number
in its line (Ni lines).The following conditions are satisfied: 1 <= Ni <= 50 000, each element of the lists lays in the range from -32768 to 32767. The first list is ascending and the second one is descending.

Output

You should write "YES" to the standard output if it is possible to choose from the two lists of integers such two numbers that their sum would be equal to 10 000. Otherwise you should write "NO".

Sample Input

4
-175
19
19
10424
3
8951
-424
-788


Sample Output

YES


Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

这么成的废话我也是醉了,不是欺负这些英语不好的么。。。
题意 有两个序列 问能不能在两个序列中各找到一个数使其和等于10000,
由于序列已经排好,直接用二分搜索的方法就可以
#include<iostream>
#include<stdio.h>
using namespace std;
int a[50004];
int main()
{
//freopen("in.txt","r",stdin);

int m;
while(~scanf("%d",&m))
{
int x;
for(int i=0;i<m;i++)
{
scanf("%d",&a[i]);
}
int n,y,flag=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&y);
if(!flag)
{
int high=m-1,low=0,mid;
while(low<=high)
{
mid=(low+high)/2;
if(a[mid]==10000-y){flag=1;break;}
else if(a[mid]>10000-y) high=mid-1;
else low=mid+1;
}
}
}
if(flag)printf("YES\n");
else printf("NO\n");
}
}


这里再贴一个看到的别人用的哈希的方法,

#include <iostream>
using namespace std;
bool hash[1000010],flag;
int n,a;
int main() {
memset(hash,false,sizeof(hash));
cin >> n;
while (n--) {
scanf("%d",&a);
hash[50000+a]=true;
}
flag=false;
cin >> n;
while (n--) {
scanf("%d",&a);
if (hash[60000-a]) {
flag=true;
break;
}
}
if (flag) printf("YES/n");
else printf("NO/n");
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: