您的位置:首页 > 编程语言 > PHP开发

hd-1092:A+B for Input-Output Practice (IV)

2015-07-20 21:28 627 查看
[align=left]Problem Description[/align]
Your task is to Calculate the sum of some integers.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 

[align=left]Sample Input[/align]

4 1 2 3 4
5 1 2 3 4 5
0

 

[align=left]Sample Output[/align]

10
15   #include <stdio.h>
int main()
{
 int n,i,a[100],sum;
 while(scanf("%d",&n)&&(n!=0))
 {
 for(i=0;i<n;i++)
 scanf("%d",&a[i]);
 for(i=0,sum=0;i<n;i++)
 sum+=a[i];
 printf("%d\n",sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: