您的位置:首页 > 其它

POJ 3279二进制枚举

2015-07-20 21:06 351 查看
Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles,
each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather
large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the
output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


只要确定了第一行,后面的就可以确定。所以只需要枚举第一行的所以情况。这里用的是二进制枚举法。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
string ans[450];
int n,m;
int cnt  =0 ;
int Map[20][20];
int aMap[20][20];
int vis[20][20];
int avis[20][20];
int dir[5][2]= {{0,0},{0,1},{1,0},{0,-1},{-1,0}};
int in(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
void flip(int x,int y,int lei)
{
    int xx,yy;
    for(int i=0; i<5; i++)
    {
        xx = x + dir[i][0];
        yy = y + dir[i][1];
        if(in(xx,yy))
        {
            if(lei==0)
            {
                if(Map[xx][yy]==1)
                    Map[xx][yy] = 0;
                else
                    Map[xx][yy] = 1;
            }
            else
            {
                if(aMap[xx][yy]==1)
                    aMap[xx][yy] = 0;
                else
                    aMap[xx][yy] = 1;
            }
        }
    }
}
void init()
{
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
            avis[i][j] = vis[i][j],aMap[i][j] = Map[i][j];
    }
}
int Min=99999999;
int solve();
int dfs()
{
    init();
    for(int i=0; i<(1<<m); i++)
    {
        for(int j=0; j<m; j++)
        {
            if(i&(1<<j))
            {
                vis[0][j] = 1;
                flip(0,j,0);
            }
        }
        init();
        solve();
        for(int j=0; j<m; j++)
        {
            if(i&(1<<j))
            {
                vis[0][j] = 0;
                flip(0,j,0);
            }
        }
    }
    return 0;
}
int check()
{

    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
            if(aMap[i][j])
                return 0;
    }
    return 1;
}
int   solve( )
{
    init();
    for(int i=1; i<n; i++)
    {
        for(int j=0; j<m; j++)
        {
            if(aMap[i-1][j]==1)
            {
                avis[i][j]= 1,flip(i,j,1);
            }
        }
    }
    if(check())
    {
        int sum = 0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
                sum+=avis[i][j];
        }
        if(sum<=Min)
        {
            Min = sum;
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<m; j++)
                    ans[cnt] +='0'+avis[i][j];
            }
            cnt++;
        }
    }
    return 0;
}
int main()
{
    memset(vis,0,sizeof(vis));
    cin>>n>>m;
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            cin>>Map[i][j];
    dfs( );
    if(cnt==0)
    {
        cout<<"IMPOSSIBLE\n";
        return 0;
    }
    sort(ans,ans+cnt);
    for(int i=0; i<cnt; i++)
    {
        int ad = 0 ;
        for(int j= 0; j<n*m; j++)
        {
            if(ans[i][j]=='1')
                ad++;
        }
        if(ad==Min)
        {
            for(int j=0; j<n*m; j++)
            {
                cout<<ans[i][j]<<" ";
                if((j+1)%m==0)
                    cout<<endl;
            }
            return 0;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: