您的位置:首页 > 编程语言 > C语言/C++

Max Sum

2015-07-17 00:32 477 查看
F - Max Sum
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000). 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
int n,m,i,j,k,sum,x,y,ma,cnt;
scanf("%d",&n);
for(cnt=1;cnt<=n;++cnt)
{
sum=0;
scanf("%d",&m);
x=1;y=m;ma=-1001,j=1;
for(i=1;i<=m;++i)
{
scanf("%d",&k);
sum+=k;
if(sum>ma)/*
(1)找到大于暂时的最大值,肯定是从(2)中来的,所以x=j就是开始时的位置
y随着sum的增大而不断刷新
*/
{
x=j;
y=i;
ma=sum;
}
if(sum<0)/*
(2)当总和小于0时,j就等于i+1,因为它知道自己没希望了,所以全部希望都压在
了未来,就是i+1
*/
{
j=i+1;
sum=0;
}
}
printf("Case %d:\n",cnt);
printf("%d %d %d\n",ma,x,y);
if(cnt!=n)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++