您的位置:首页 > 编程语言 > C语言/C++

Piggy-Bank

2015-07-19 23:05 309 查看
L - Piggy-Bank
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.". 

 

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

 

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

思路:  一开始就知道是多重背包了,但是却想错方向,以为是价值的背包,结果总是想不出来。最后还是写了个关于个数的与重量相关的背包,发现了一个规律,能恰好装满必须是体积v的倍数才行,所以动态转移方程如下:i=物品个数,j=变化的重量〉w,w=当前物品重量,k=当前物品取多少个,v=物品价值Dp[i][w]=min(dp[i-1][j],dp[i-1][j-k*w]+k*v);其实物品个数只和以前有关,而且动态规划无滞后性,所以可以省掉二维,利用滚动数组就行了,代码如下:(时间很大:920ms,勉强过了)

AC代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
const int T=10100;
int dp[T];
void INIT(int v)
{
for(int i=0;i<=v;++i)
{
dp[i]=0x3f3f3f3f;
}
dp[0]=0;
}
int main()
{
int N,n,m,p,w,i,j,k,v;
scanf("%d",&N);
while(N--)
{
scanf("%d%d",&n,&m);
v=m-n;INIT(v);
scanf("%d",&n);
for(i=0;i<n;++i)
{
scanf("%d%d",&p,&w);
for(j=v;j>=w;--j)
{
for(k=1;k*w<=j;++k)
{
dp[j]=min(dp[j],dp[j-k*w]+k*p);
}
}
}
if(dp[v]!=0x3f3f3f3f)
printf("The minimum amount of money in the piggy-bank is %d.\n",dp[v]);
else
printf("This is impossible.\n");
}
return 0;
}


关于上面代码其实还可以优化一下,因为吴老师讲过了关于多重背包是可以降维的。上面的转移方程可以变为
Dp[i][j]=min(dp[i-1][j],dp[i][j-w]+v);
这样子明显是逆序是不行的了,因为他的i已不是i-1了,所以必须要知道了i后的值才能推出dp[i][j]。所以要顺序循环。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  背包 c++