您的位置:首页 > 其它

POJ 1064 Cable master (二分 分数化整数)

2015-07-16 23:01 459 查看
Cable master
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28764Accepted: 6091
Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to
connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance
from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants
as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not
known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested
pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter
precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a
centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39

Sample Output
2.00

Source
Northeastern Europe 2001

题目链接:http://poj.org/problem?id=1064

题目大意:有n根绳子,每根长用一个精度为0.01的实数表示,现在要把全部分成等长的k份,问每份最长是多少

题目分析:典型的二分题,可以直接二分小数,但是不推荐这样,二分小数有很多细节不好处理,直接.2f好像会自动四舍五入,因为题目给的都是保留两位的,直接乘100转换成整数二分,最后输出的时候除100.0,这样貌似就不会四舍五入了。

#include <cstdio>
#include <algorithm>
using namespace std;
int a[10005];
int n, k;

bool ok(int m)
{
	int cnt = 0;
    for(int i = 0; i < n; i++)
        cnt += a[i] / m;
    return cnt >= k;
}

int main()
{
    while(scanf("%d %d", &n, &k) != EOF)
    {
        int ma = 0;
        for(int i = 0; i < n; i++)
        {
        	double tmp;
            scanf("%lf", &tmp);
            a[i] = (int)(tmp * 100);
            ma = max(ma, a[i]);
        }
        int r = ma, l = 1;
        while(l <= r)
        {
            int mid = (l + r) / 2;
            if(ok(mid)) 
            	l = mid + 1;
            else
                r = mid - 1;
        }
        //注意这里答案是r不是l,因为cnt比k小是符合条件的,大于k就不符合条件了
        printf("%.2f\n", (double)r / 100.0);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: