您的位置:首页 > 其它

Frogger - poj 2253 (Dijkstra)

2015-07-10 10:41 357 查看
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 28802Accepted: 9353
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
这题可以用Dijkstra,将松弛条件改一下就可以了,改成

if(dis[j]>max(dis[stone],map[stone][j])&&(vis[j]==0)){
dis[j]=max(dis[stone],map[stone][j]);
}

这样的结果就是求得能到达这点的路径上的最长边的最小值,求输出时要注意格式


#include <iostream>
#include<math.h>
#include<limits.h>
#include<algorithm>
#include<iomanip>
using namespace std;
int num;
int vis[200],stone[200][2];
int map[200][200],dis[200];
int Dijkstra(){
for(int i=0;i<num;i++){
dis[i]=INT_MAX;
vis[i]=0;
}
dis[0]=0;
for(int i=0;i<num;i++){
int min=INT_MAX;
int stone;
for(int j=0;j<num;j++){
if((vis[j]==0)&&min>dis[j]){
stone=j;
min=dis[j];
}
}
vis[stone]=1;
if(min==INT_MAX)
break;
for(int j=0;j<num;j++){
if(dis[j]>max(dis[stone],map[stone][j])&&(vis[j]==0)){
dis[j]=max(dis[stone],map[stone][j]);
}
}
}
return dis[1];
}

int main() {

cin>>num;
int count=1;
while(num){
for(int i=0;i<num;i++){
cin>>stone[i][0]>>stone[i][1];
}
for(int i=0;i<num;i++){
for(int j=0;j<num;j++){
map[i][j]=pow((stone[i][0]-stone[j][0]),2)+pow((stone[i][1]-stone[j][1]),2);
}
}
float  fdis=sqrt(Dijkstra());
cout<<fixed;
cout<<"Scenario #"<<count<<endl<<"Frog Distance = "<<setprecision(3)<<fdis<<endl<<endl;

count++;
cin>>num;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: