您的位置:首页 > 其它

POJ 1195 Mobile phones(二维树状数组)

2015-07-09 00:10 218 查看
Mobile phones

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 16320Accepted: 7502
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table.



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output
3
4

Source
题意:输入 0 n 表示创建一个n*n的矩阵,初始化为0
输入1 x y v 将点(x,y)的值加上v,如果v小于0,则(x,y)的值最小只能减到0
输入 2 x y x1 y1 求子矩阵(x,y)~(x1,y1)的和
输入3 结束
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#define N 1040
#define ll long long

using namespace std;

int n;

int bit

;
int a

;

ll sum(int i,int j) {
    ll s=0;
    while(i>0) {
        int jj=j;
        while(jj>0) {
            s+=bit[i][jj];
            jj-=jj&-jj;
        }
        i-=i&-i;
    }
    return s;
}

void add(int i,int j,int x) {
    while(i<=n) {
        int jj=j;
        while(jj<=n) {
            bit[i][jj]+=x;
            jj+=jj&-jj;
        }
        i+=i&-i;
    }
}
int main() {
    //freopen("test.in","r",stdin);
    int op;
    while(scanf("%d",&op)) {
        if(op==3)break;
        if(op==0) {
            scanf("%d",&n);
            memset(bit,0,sizeof bit);
            memset(a,0,sizeof a);
            continue;
        }
        if(op==1) {
            int x,y,v;
            scanf("%d%d%d",&x,&y,&v);
            x++,y++;
            if(v<0) {
                if(a[x][y]+v<0) {
                    //a[x][y]=0;
                    v=-1*a[x][y];
                }
            }
            a[x][y]+=v;
            add(x,y,v);
            continue;
        }
        ll ans=0;
        int lx,ly,rx,ry;
        scanf("%d%d%d%d",&lx,&ly,&rx,&ry);
        lx++,ly++,rx++,ry++;
        ans=sum(rx,ry)-sum(lx-1,ry)-sum(rx,ly-1)+sum(lx-1,ly-1);
        printf("%lld\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: