您的位置:首页 > 其它

POJ 1318 Word Amalgamation (字符串 STL大水)

2015-07-04 00:34 381 查看
Word Amalgamation
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 8665Accepted: 4172
Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is
necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input
The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more
scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will
be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a
line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input
tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output
score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

Source
Mid-Central USA 1998

题目链接:http://poj.org/problem?id=1318

题目大意:给一个字典,"XXXXXX"结束,再输入一些打乱的字母,"XXXXXX"结束,现在重排这些字母,问重排后的单词是否出现在字典中,出现就输出,可能有不同多个

题目分析:因为单词长度最大为6,直接next_permutation,字典用set存,0ms

代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
#include <set>
using namespace std;

int main()
{
    int cnt = 0;
    string s;
    set <string> st;
    set <string> :: iterator it;
    while(cin >> s)
    {
        if(s == "XXXXXX")
        {
            cnt ++;
            continue;
        }
        if(cnt == 2)
            break;
        if(cnt == 0)
            st.insert(s);
        else if(cnt == 1)
        {
            bool flag = false;
            sort(s.begin(), s.end());
            do
            {
                it = st.find(s);
                if(it != st.end())
                {
                    flag = true;
                    cout << s << endl;
                }
            }while(next_permutation(s.begin(), s.end()));
            if(!flag)
                printf("NOT A VALID WORD\n");
            printf("******\n");
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: