您的位置:首页 > 其它

POJ 3268 Silver Cow Party (来回最短路 SPFA)

2015-07-07 10:59 357 查看
Silver Cow Party
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 14384Accepted: 6490
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤X ≤N). A total ofM (1 ≤
M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; roadi requiresTi (1 ≤Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the
party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:N,M, andX

Lines 2..M+1: Line i+1 describes road i with three space-separated integers:Ai,Bi, andTi. The described road runs from farmAi to farmBi,
requiringTi time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
Source
USACO 2007 February Silver

题目链接:http://poj.org/problem?id=3268

题目大意:奶牛聚会,求所有奶牛从自己农场到目标农场再回到自己农场的最短路中的最大值,路是单向的

题目分析:与POJ 1511类似,从自己到目标农场进行n-1次SPFA,记录每个dis[x],然后一次SPFA(x),记录每个dis[i],最后两个值加起来取大即可,复杂度O(nm)感觉过不了,可是300ms+过了

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
int const INF = 0x3fffffff;
int const MAX = 1005;
int dis[MAX], re1[MAX], re2[MAX];
bool vis[MAX];
int n, m, x;

struct EGDE
{
    int u, v, t;
}e[MAX * MAX / 2];

struct NODE
{
    int v, t;
    NODE(int vv, int tt)
    {
        v = vv;
        t = tt;
    }
};

vector <NODE> vt[MAX];

void SPFA(int v0)
{
    for(int i = 1; i <= n; i++)
        dis[i] = INF;
    dis[v0] = 0;
    queue <int> q;
    q.push(v0);
    memset(vis, false, sizeof(vis));
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = false;
        int sz = vt[u].size();
        for(int i = 0; i < sz; i++)
        {
            int v = vt[u][i].v;
            int t = vt[u][i].t;
            if(dis[v] > dis[u] + t)
            {
                dis[v] = dis[u] + t;
                if(!vis[v])
                {
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
    return;
}

int main()
{
    for(int i = 0; i <= n; i++)
        vt[i].clear();
    scanf("%d %d %d", &n, &m, &x);
    for(int i = 0; i < m; i++)
        scanf("%d %d %d", &e[i].u, &e[i].v, &e[i].t);
    for(int i = 0; i < m; i++)
        vt[e[i].u].push_back(NODE(e[i].v, e[i].t));
    for(int i = 1; i <= n; i++)
    {
        if(i == x)
        {
            continue;
            re1[i] = 0;
        }
        SPFA(i);
        re1[i] = dis[x];
    }
    SPFA(x);
    for(int i = 1; i <= n; i++)
        re2[i] = dis[i];
    int ans = 0;
    for(int i = 1; i <= n; i++)
        ans = max(ans, re1[i] + re2[i]);
    printf("%d\n", ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: