您的位置:首页 > 产品设计 > UI/UE

1041. Be Unique (20)

2015-07-02 09:26 801 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1041

题目:


1041. Be Unique (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


分析:

输入一组数,输出其中第一个出现的不成对的数

用一个vector存储一下输入。用一个数组来计数,难度不大

AC代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<vector>
using namespace std;
vector<int>V;
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 int ans[10001];//用ans[]来计数
 memset(ans, 0, sizeof(ans));
 V.clear();
 int n;
 cin >> n;
 for (int i = 0; i < n; i++){
  int m;
  cin >> m;
  ans[m] ++;
  V.push_back(m);//用V来保持原有数的顺序
 }
 for (int i = 0; i < n; i++){
  if (ans[V[i]] == 1){
   cout << V[i] << endl;
   return 0;
  }
 }
 cout << "None" << endl;
 return 0;
}


截图:



——Apie陈小旭
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: