您的位置:首页 > 其它

1045. Favorite Color Stripe (30)

2015-09-04 13:59 344 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1045

题目:

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length.
So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best
solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200)
followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by
a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.
Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:
7


分析:

采用之前和PATTAP一样的思路,O(n)的解法,可以得到高效的算法

先把喜欢的序列给编号:

喜欢颜色序列:2 3 1 5 6

喜欢颜色编号:1 2 3 4 5

然后把它对应到已有序列上面去

原颜色序列 2 2 4 1 5 5 6 3 1 1 5 6

最后的max:[1] [2] 0 [3] [4] [5] [6] [3] [4] [5] [6] [7]

映射之后的: 1 1 0 3 4 4 5 2 3 3 4 5

因为我们知道它一定要按照序列排,也就是说最后的序列一定要去递增的

时间复杂度是O(M*L)。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int stripe[10002];//存放彩带
int like[202];//存放喜欢序列
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n;
 scanf("%d", &n);
 int n_like;//喜欢的颜色序列个数
 memset(like, 0, sizeof(like));
 memset(stripe, 0, sizeof(stripe));//init
 scanf("%d", &n_like);
 for (int i = 1; i <= n_like; i++){
  int tmp;
  scanf("%d", &tmp);
  like[tmp] = i;//喜欢颜色序列做一个映射
 }
 int num;
 scanf("%d", &num);
 for (int i = 1; i <= num; i++){
  int tmp;
  scanf("%d", &tmp);
  stripe[i] = like[tmp];//变成映射后的彩带序列
 }
 int max;
 int big[1002];
 memset(big, 0, sizeof(big));
 for (int i = 1; i <= num; i++){
  if (stripe[i] == 0)continue;//表示当前颜色不在喜欢的颜色序列中
  max = 0;
  for (int j = 1; j <= stripe[i]; j++){
   if (max <= big[j]){//找到当前颜色之前累计数量最多的颜色
    max = big[j];
   }
  }
  big[stripe[i]] = max + 1;//把当前颜色添加到最多的颜色之后,形成最长序列
 }
 max = 0;
 for (int i = n_like; i >= 1; i--){//找到最大值
  if (big[i] > max)max = big[i];
 }
 printf("%d\n", max);
 return 0;
}


截图:



——Apie陈小旭
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: