您的位置:首页 > 其它

nyoj216

2015-06-29 00:20 381 查看
A problem is easy
        时间限制:1000 ms  |  内存限制:65535 KB
        难度:3
        描述


When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..




One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

输入

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).

输出

For each case, output the number of ways in one line

样例输入

2

1

3

样例输出

0

1

一下子没想到!

看下吧! 代码ac

#include<stdio.h>
int main()
{
    long long  n,m;
    scanf("%lld",&m);
    while(m--)
    {
        scanf("%lld",&n);
        int i,s=0;
    for(i=1;(i+1)*(i+1)<=n+1;i++)
     {
        if((n+1)%(i+1)==0)
        s++;
     }
     printf("%d\n",s);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: