您的位置:首页 > 编程语言 > C语言/C++

北大百炼1006 Biorhythms 题解

2015-06-25 20:21 369 查看

1006:Biorhythms

c007

总时间限制: 3000ms 内存限制: 65536kB
描述Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and
33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper
and concentration will be easier. 

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will
be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine
the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give
the number of days to the next occurrence of a triple peak.

输入You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical,
emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date.
The end of input is indicated by a line in which p = e = i = d = -1.
输出For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.
样例输入
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1


样例输出
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.


题目大意:

给出三个生理期达到巅峰的初始值,给出现在的时间,求在多少天后,三个周期达到巅峰的时间为同一天。

AC代码

#include<stdio.h>
#include<math.h>

int main()
{
int a,b,c,d,j=0;
while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
{
if(a<0||b<0||c<0||d<0)
break;
j++;
a=a%23;
b=b%28;
c=c%33;
int m=c;

while(!((m-a)%23==0&&((m-b)%28==0)))
{
m=m+33;

}

m=m-d;
if(m<=0)
m=m+23*28*33;
printf("Case %d: the next triple peak occurs in %d days.\n",j,m);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息