您的位置:首页 > 编程语言 > C语言/C++

北大百炼1004 Financial Management 题解

2015-06-25 20:10 429 查看

1004:Financial Management

总时间限制: 1000ms 内存限制: 65536kB
描述Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems.
The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate
his average account balance.
输入The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
输出The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There
will be no other spaces or characters in the output.
样例输入
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75


样例输出
$1581.42


题目大意:

给出Larry 12个月的账户余额,求Larry每月的平均账户余额。

AC代码

#include<stdio.h>
#include<math.h>

int main()
{
int i;
double s=0,n;
for(i=1;i<=12;i++)
{
scanf("%lf",&n);
s=s+n;
}
s=s*1.0/12;
printf("$%.2lf\n",s);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息