您的位置:首页 > 移动开发

POJ3321:Apple Tree(树状数组)

2015-06-25 11:16 423 查看
Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are
there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?



Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.

The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.

The next line contains an integer M (M ≤ 100,000).

The following M lines each contain a message which is either

"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.

or

"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x

Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.
Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output
3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题意:

给出一个苹果树,每个节点一开始都有苹果

C X,如果X点有苹果,则拿掉,如果没有,则新长出一个

Q X,查询X点与它的所有后代分支一共有几个苹果

思路:

思路很巧妙,我们通过自己来编号所有苹果,每个节点保存两个值,左值为本身,右值为其包含的所有后代中最大的编号

我们可以通过搜索来进行编号,在编好号之后,我们可以知道,对于某一点而言,我们是先通过这个点搜完所有他的后代编号才结束的,所以这个点的右值,包含了当前点所有的后代与祖先,后代必然是所有编号大于本节点的点,那么祖先呢,那必然是编号小于这个节点的点了

所以我们通过sum(rig[x])-sum(lef[x]-1)就能得到查询的答案

至于更新,只需要更新当前点即可,这样就转化为树状数组了

一开始我vector使用的vector<int> a
,但是一直超时,开始我还没有发现是这个的问题

后来参考别人的发现没什么不同,唯一差别的地方就在这里,于是尝试着修改成vector<vector<int> > a(N),结果就A了,坑啊

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7;

vector<vector<int> > a(N);
//vector<int> a
;
int n,m,lef
,rig
,c
,tot,s
;

int sum(int x)
{
    int ret = 0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}

void dfs(int x)
{
    lef[x] = tot;
    for(int i = 0; i<a[x].size(); i++)
    {
        tot++;
        dfs(a[x][i]);
    }
    rig[x] = tot;
}
int main()
{
    int i,j,k,x,y;
    char op[5];
    while(~scanf("%d",&n))
    {
        MEM(lef,0);
        MEM(rig,0);
        MEM(s,0);
        MEM(c,0);
        for(i=0; i<N; i++)
            a[i].clear();
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            a[x].push_back(y);
        }
        tot = 1;
        dfs(1);
        for(i = 1; i<=n; i++)
        {
            s[i] = 1;
            add(i,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%d",op,&x);
            if(op[0]=='Q')
            {
                printf("%d\n",sum(rig[x])-sum(lef[x]-1));
            }
            else
            {
                if(s[x])
                    add(lef[x],-1);
                else
                    add(lef[x],1);
                s[x]=!s[x];
            }
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: